package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d+(\.\d+)*\b`)
var str = `1.1 2 2.1 3.12324132.42.42 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}