package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`1\d{10}`)
var str = `17621978451`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}