package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*(true|false)\s*$`)
var str = `false`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}