# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*[a-zA-Z]+.*\..*[a-zA-Z]+.*\..*(~|\-|\+)*[a-zA-Z0-9]+$"
test_str = ("//good\n"
"1c.1c.0\n"
"v1c.1.asdf\n"
"errhand.LSD.asdf+dfsg\n"
"1.c1.asdf\n"
"c1.1.asdf\n"
"c1c.1.asdf\n"
"1.c1cc.asadf~dsf\n\n"
"//bad\n"
"1.1\n"
"1.1.1\n"
"1.00.00\n"
"v1c.1.\n"
"1.v1c.\n"
"1.01.01~sdgf\n"
"1.v1c.asdf-sadf+asdf\n"
"~1c.1c.0\n"
"1c.1~c.0")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.