package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(https?:\/\/)?([\da-z\.-]+)\.([a-z\.]{2,6})([\/\w \.-]*)*\/?$`)
var str = `http://www.bbc.co.uk/food/recipes/bourbon-glazed_monster_11608`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}