# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d+年\d+月\d+日).*新增本土.*确诊病例(\d+)例.*无症状感染者(\d+)例.*其中(\d+)例确诊病例为此前无症状.*,(\d+)例确诊病例和(\d+)例无症状感染者.*相关风险人群排查中发现"
test_str = ("市卫健委今早(22日)通报:2022年4月21日0—24时,新增本土新冠肺炎确诊病例1931例和无症状感染者15698例,其中143例确诊病例为此前无症状感染者转归,1685例确诊病例和15551例无症状感染者在隔离管控中发现,其余在相关风险人群排查中发现\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.