import Foundation
let pattern = #"date_modified(?<date_modified>(?:.*?\n?)*?)internal_id(?<internal_id>(?:.*?\n?)*?)task(?<task>(?:.*?\n?)*?)priority(?<priority>(?:.*?\n?)*?)status(?<status>(?:.*?\n?)*?)task_status(?<task_status>(?:.*?\n?)*?)created(?<created>(?:.*?\n?)*?)assigned(?<assigned>(?:.*?\n?)*?)date_created(?<date_created>(?:.*?\n?)*?)date_started(?<date_started>(?:.*?\n?)*?)date_due(?<date_due>(?:.*?\n?)*?)date_completed(?<date_completed>(?:.*?\n?)*?)bunit(?<bunit>(?:.*?\n?)*?)task_vendor(?<task_vendor>(?:.*?\n?)*?)task_category(?<task_category>(?:.*?\n?)*?)customer(?<customer>(?:.*?\n?)*?)cust_name(?<cust_name>(?:.*?\n?)*?)cust_territory(?<cust_territory>(?:.*?\n?)*?)contact(?<contact>(?:.*?\n?)*?)time_date(?<time_date>(?:.*?\n?)*?)time_duration(?<time_duration>(?:.*?\n?)*?)comment(?<comment>(?:.*?\n?)*?)opportunity(?<opportunity>(?:.*?\n?)*?)opp_status(?<opp_status>(?:.*?\n?)*?)opp_engineer(?<opp_engineer>(?:.*?\n?)*?)transaction(?<transaction>(?:.*?\n?)*?)yeg_id(?<yeg_id>(?:.*?\n?)*?)Recent Changes"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
date_modified21-DECEMBER-2020 12:25 PMinternal_id313017task2nd Year Annual
billing pricing -34515priorityMediumstatusCompletedtask_statusAllocatedcreated
Bernadine PereraassignedBernadine Pereradate_created21-DECEMBER-2020 12:25 PM
date_started21-DECEMBER-2020date_due21-DECEMBER-2020date_completed
21-DECEMBER-2020bunitOperationstask_vendorSplunktask_categoryOthercustomer
cust_namecust_territorycontacttime_datetime_durationcommentopportunityopp_status
opp_engineertransaction yeg_idRecent Changes
DateSet byContextTypeFieldOld ValueNew Value21-DECEMBER-2020 12:25 PMBernadine
PereraUISetStart Date21-DECEMBER-2020 12:00 Utc21-DECEMBER-2020 12:25 PM
Bernadine PereraUISetOwnerBernadine Perera21-DECEMBER-2020 12:25 PMBernadine
PereraUISetAssignedBernadine Perera21-DECEMBER-2020 12:25 PMBernadine PereraUI
SetBusiness UnitOperations21-DECEMBER-2020 12:25 PMBernadine PereraUISetTask
CategoryOther21-DECEMBER-2020 12:25 PMBernadine PereraUISetTask StateAllocated
21-DECEMBER-2020 12:25 PMBernadine PereraUISetTask VendorSplunk21-DECEMBER-2020
12:25 PMBernadine PereraUICreateRecordTASK313017You requested to receive an
email alert for this record. Click here to modify your email alerts
[https://55349.app.netsuite.com/app/center/userprefs.nl?sc=-29&selectedtab=alerts]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)