# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^\040*)(\w*)(\040*)(=)(\040*)(\w*$|\".*)"
test_str = ("# '#' character is used for comments - like in Bash\n"
"# '*' character is a wildcart character, \".*\" is the regex equivalence\n\n"
"# set x-ambles, the strings to be printed before, in-between and after the group of bitfields\n"
"preamble=\"#ifdef DEBUG\"\n"
"interamble=#else\n"
"postamble=#endif\n\n"
"# set the alignment value\n"
"alignment=16\n\n"
"# bitfield names to be ignored\n"
"ignore=padding*,dummy*,doNotCare* \n\n"
"# indent \n"
"indent=\" \"\n\n"
"# padding type\n"
" padding = unsigned\n\n"
"# this whould not be searched by C++ engine \n"
"files=*.h,*.c\n\n"
"#prefix of type name to be searched\n"
"prefix=typedef\n\n"
"#do or do not mirror\n"
"mirror=true\n\n"
"#for regex testig\n"
"mirror=$\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.