#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(?!(?!.*?<a)[^<]*<\/a>)(?<!")(?:(?:https?|ftp|file):\/\/|www\.|ftp\.|youtube\.|youtu\.be)[\-A-Z0-9\+\&\#\/%=~_|$?!:;,\.]*[A-Z0-9+&#\/%=~_|$]"
Local $sString = "youtu.be/iwGFalTRHDA" & @CRLF & _
"youtube.com/watch?v=iwGFalTRHDA" & @CRLF & _
"www.youtube.com/watch?v=iwGFalTRHDA" & @CRLF & _
"http://www.youtube.com/watch?v=iwGFalTRHDA" & @CRLF & _
"https://www.youtube.com/watch?v=iwGFalTRHDA" & @CRLF & _
"https://www.youtube.com/watch?v=MoBL33GT9S8&feature=share" & @CRLF & _
"https://www.youtube.com/embed/watch?feature=player_embedded&v=iwGFalTRHDA" & @CRLF & _
"https://www.youtube.com/embed/watch?v=iwGFalTRHDA" & @CRLF & _
"https://www.youtube.com/embed/v=iwGFalTRHDA" & @CRLF & _
"https://www.youtube.com/watch/iwGFalTRHDA" & @CRLF & _
"http://www.youtube.com/attribution_link?u=/watch?v=aGmiw_rrNxk&feature=share" & @CRLF & _
"https://m.youtube.com/watch?v=iwGFalTRHDA" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/watch?v=DFYRQ_zQ-gk&feature=featured" & @CRLF & _
"https://www.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"http://www.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"//www.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"www.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"https://youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"http://youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"//youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"" & @CRLF & _
"https://m.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"http://m.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"//m.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"m.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US" & @CRLF & _
"http://www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US" & @CRLF & _
"//www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US" & @CRLF & _
"www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US" & @CRLF & _
"youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/embed/DFYRQ_zQ-gk?autoplay=1" & @CRLF & _
"https://www.youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"http://www.youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"//www.youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"www.youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"https://youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"http://youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"//youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"" & @CRLF & _
"https://youtu.be/DFYRQ_zQ-gk?t=120" & @CRLF & _
"https://youtu.be/DFYRQ_zQ-gk" & @CRLF & _
"http://youtu.be/DFYRQ_zQ-gk" & @CRLF & _
"//youtu.be/DFYRQ_zQ-gk" & @CRLF & _
"youtu.be/DFYRQ_zQ-gk" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/HamdiKickProduction?v=DFYRQ_zQ-gk" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""https://youtu.be/yVpbFMhOAwE"," & @CRLF & _
""https://www.youtube.com/embed/yVpbFMhOAwE"," & @CRLF & _
""youtu.be/yVpbFMhOAwE"," & @CRLF & _
""youtube.com/watch?v=yVpbFMhOAwE"," & @CRLF & _
""http://youtu.be/yVpbFMhOAwE&t=2m"," & @CRLF & _
""http://www.youtube.com/embed/yVpbFMhOAwE&t=2m5s"," & @CRLF & _
""http://www.youtube.com/watch?v=yVpbFMhOAwE"," & @CRLF & _
""http://www.youtube.com/watch?v=yVpbFMhOAwE&feature=g-vrec&t=30s"," & @CRLF & _
""http://www.youtube.com/watch?v=yVpbFMhOAwE&feature=player_embedded"," & @CRLF & _
""http://www.youtube.com/v/yVpbFMhOAwE?fs=1&hl=en_US"," & @CRLF & _
""http://www.youtube.com/ytscreeningroom?v=yVpbFMhOAwE"," & @CRLF & _
""http://www.youtube.com/watch?NR=1&feature=endscreen&v=yVpbFMhOAwE"," & @CRLF & _
""http://www.youtube.com/user/Scobleizer#p/u/1/1p3vcRhsYGo"," & @CRLF & _
""http://www.youtube.com/watch?v=6zUVS4kJtrA&feature=c4-overview-vl&list=PLbzoR-pLrL6qucl8-lOnzvhFc2UM1tcZA"," & @CRLF & _
""https://www.youtube.com/watch?v=FZu097wb8wU&list=RDFZu097wb8wU"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"youtu.be/iwGFalTRHDA" & @CRLF & _
"youtube.com/watch?v=iwGFalTRHDA" & @CRLF & _
"www.youtube.com/watch?v=iwGFalTRHDA" & @CRLF & _
"http://www.youtube.com/watch?v=iwGFalTRHDA" & @CRLF & _
"https://www.youtube.com/watch?v=iwGFalTRHDA" & @CRLF & _
"https://www.youtube.com/watch?v=MoBL33GT9S8&feature=share" & @CRLF & _
"https://www.youtube.com/embed/watch?feature=player_embedded&v=iwGFalTRHDA" & @CRLF & _
"https://www.youtube.com/embed/watch?v=iwGFalTRHDA" & @CRLF & _
"https://www.youtube.com/embed/v=iwGFalTRHDA" & @CRLF & _
"https://www.youtube.com/watch/iwGFalTRHDA" & @CRLF & _
"http://www.youtube.com/attribution_link?u=/watch?v=aGmiw_rrNxk&feature=share" & @CRLF & _
"https://m.youtube.com/watch?v=iwGFalTRHDA" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/watch?v=DFYRQ_zQ-gk&feature=featured" & @CRLF & _
"https://www.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"http://www.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"//www.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"www.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"https://youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"http://youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"//youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"" & @CRLF & _
"https://m.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"http://m.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"//m.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"m.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US" & @CRLF & _
"http://www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US" & @CRLF & _
"//www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US" & @CRLF & _
"www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US" & @CRLF & _
"youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/embed/DFYRQ_zQ-gk?autoplay=1" & @CRLF & _
"https://www.youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"http://www.youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"//www.youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"www.youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"https://youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"http://youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"//youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"" & @CRLF & _
"https://www.youtube-nocookie.com/embed/DFYRQ_zQ-gk?autoplay=1" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"https://youtu.be/DFYRQ_zQ-gk?t=120" & @CRLF & _
"https://youtu.be/DFYRQ_zQ-gk" & @CRLF & _
"http://youtu.be/DFYRQ_zQ-gk" & @CRLF & _
"//youtu.be/DFYRQ_zQ-gk" & @CRLF & _
"youtu.be/DFYRQ_zQ-gk" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/HamdiKickProduction?v=DFYRQ_zQ-gk" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/feed/subscriptions" & @CRLF & _
"https://www.youtube.com/channel/UCgc00bfF_PvO_2AvqJZHXFg" & @CRLF & _
"https://www.youtube.com/c/NatGeoEdOrg/videos" & @CRLF & _
"" & @CRLF & _
" youtu.be/iwGFalTRHDA" & @CRLF & _
"youtube.com/watch?v=iwGFalTRHDA" & @CRLF & _
"www.youtube.com/watch?v=iwGFalTRHDA" & @CRLF & _
"http://www.youtube.com/watch?v=iwGFalTRHDA" & @CRLF & _
"https://www.youtube.com/watch?v=iwGFalTRHDA" & @CRLF & _
"https://www.youtube.com/watch?v=MoBL33GT9S8&feature=share" & @CRLF & _
"https://www.youtube.com/embed/watch?feature=player_embedded&v=iwGFalTRHDA" & @CRLF & _
"https://www.youtube.com/embed/watch?v=iwGFalTRHDA" & @CRLF & _
"https://www.youtube.com/embed/v=iwGFalTRHDA" & @CRLF & _
"https://www.youtube.com/watch/iwGFalTRHDA" & @CRLF & _
"http://www.youtube.com/attribution_link?u=/watch?v=aGmiw_rrNxk&feature=share" & @CRLF & _
"https://m.youtube.com/watch?v=iwGFalTRHDA"
Local $sSubst = "<a href="$0">$0</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)