$re = '/(?=>([$0-9,\.]*))/i';
$str = '<span class="amount">$1,876.20</span>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);