$re = '/(.*?)[.\s][sS](\d{1,2})[eE](\d{1,3}).*/';
$str = 'Game of thrones s1e1';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);