re = /^[a-zA-Z0-9._%+-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,6}$/
str = 'rdiaz@etechnologiesgroup.com
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end