re = /^(?![ -.&,_'":?!])(?!.*[- &_'":]$)(?!.*[-.#@&,:?!]{2})[a-zA-Z0-9- .#@&,_'":.?!]+$/m
str = 'Building 3, Level 4 - Dubai Internet City'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end