re = /^(?=.*[A-Z])(?=.*[!@#$&*])(?=.*[0-9])(?=.*[a-z]).{8,16}$/
str = 'P@ssw0rd'
# Print the match result
str.match(re) do |match|
puts match.to_s
end