package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[a-zA-Z]+([A-Z][a-z]+)+$`)
var str = `CRSelectedString`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}