#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((((2(0[1-9]|[1-9][0-9]))|([3-6][0-9]{2})|(7([0-6][0-9]|7[0-5])))[0-9]{6})|((0|8)((2(0[1-9]|[1-9][0-9]))|([3-6][0-9]{2})|(7([0-6][0-9]|7[0-5])))[0-9]{5})|((00|99|98)((2(0[1-9]|[1-9][0-9]))|([3-6][0-9]{2})|(7([0-6][0-9]|7[0-5])))[0-9]{4})|(111((2(0[1-9]|[1-9][0-9]))|([3-6][0-9]{2})|(7([0-6][0-9]|7[0-5])))[0-9]{3})|((970|972|974)[0-9]{6}))$"
Local $sString = "000000000" & @CRLF & _
"1193046" & @CRLF & _
"100000000" & @CRLF & _
"111111111" & @CRLF & _
"123456789" & @CRLF & _
"222222222" & @CRLF & _
"999999999" & @CRLF & _
"201000000" & @CRLF & _
"200123456" & @CRLF & _
"775123456" & @CRLF & _
"776123456" & @CRLF & _
"7751234562" & @CRLF & _
"111456000" & @CRLF & _
"077500000" & @CRLF & _
"877500000" & @CRLF & _
"002010000" & @CRLF & _
"995642323" & @CRLF & _
"988885687" & @CRLF & _
"986885687" & @CRLF & _
"970123456" & @CRLF & _
"972000000" & @CRLF & _
"974999999" & @CRLF & _
"975999999" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")