$re = '/(?<!=[ ])(?<![=&|%])(\+|-)(?!\1|[ =])/m';
$str = 'a - b + c
a-b+c
a-=2
a=-2
a&-b
a|-2
a%-b
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);