$re = '/\.0*([1-9]+)$/';
$str = '001.39622.001979';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);