# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)"
test_str = ("[::1]\n"
"[:a:1]\n"
"[:bh:lh:1]\n"
"[1:1:fEd1:1:abdc:1]\n"
"[::ffff:192.0.2.128]\n"
"[0000:0000:0000:0000:0000:0000:0000:0001]\n"
"[2001:0db8:0000:0000:0000:ff00:0042:8329]\n"
"[2001:db8:0:0:0:ff00:42:8329]\n"
"[2001:db8::ff00:42:8329]\n"
"[2001:0db8:0000:0000:0000:ff00:0042:8329]\n\n"
"::1\n"
":a:1\n"
":bh:lh:1\n"
"1:1:fEd1:1:abdc:1\n"
"::ffff:192.0.2.128\n"
"0000:0000:0000:0000:0000:0000:0000:0001\n"
"2001:0db8:0000:0000:0000:ff00:0042:8329\n"
"2001:db8:0:0:0:ff00:42:8329\n"
"2001:db8::ff00:42:8329\n"
"2001:0db8:0000:0000:0000:ff00:0042:8329\n\n"
"United Kingdom , London\n"
"IP: 91.149.202.91\n"
"IPv6: 2605:e440:8::2:1b\n"
"http://91.149.202.91/1000MB.test\n"
"http://[2605:e440:8::2:1b]/1000MB.test")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.