$re = '/\<td\>(.{2,5})\<\/td\>/i';
$str = '<form method=\'get\' action=\'/cgi-bin/webcmd\'><pre><input type=\'hidden\' name=\'screen\' value=\'Qam\'>Which EdgeQam (192.168.6.1+chassis): <input type=\'text\' name=\'Qam\' value=\'192.168.6.2\'>
<input type=\'submit\'> <input type=\'submit\' name=\'qamLog\' value=\'qamLog\'></pre></form>
<h2>Mega-Bits Per Second</h2>Port = QamChannel * 16 + QamSubChannel
<table border cellspacing=0 cellpadding=5> <tr><td></td><td>PortBase</td><td>Chan</td><td>-1</td><td>-2</td><td>-3</td><td>-4</td><td>total</td></tr><tr><td>Qam1</td>
<td>16</td><td>23</td><td>4.7</td><td>4.5</td><td>6.3</td><td>0.1</td><td>15.6</td></tr>
<tr><td>Qam2</td>
<td>32</td><td>24</td><td>6.3</td><td>8.0</td><td>7.3</td><td>0.2</td><td>21.8</td></tr>
<tr><td>Qam3</td>
<td>48</td><td>25</td><td>5.6</td><td>9.9</td><td>6.0</td><td>0.2</td><td>21.6</td></tr>
<tr><td>Qam4</td>
<td>64</td><td>26</td><td>5.5</td><td>7.2</td><td>6.8</td><td>0.2</td><td>19.6</td></tr>
<tr><td>Qam5</td>
<td>80</td><td>27</td><td>8.8</td><td>4.5</td><td>7.4</td><td>0.2</td><td>21.0</td></tr>
<tr><td>Qam6</td>
<td>96</td><td>28</td><td>8.4</td><td>5.1</td><td>7.5</td><td>0.2</td><td>21.3</td></tr>
<tr><td>Qam7</td>
<td>112</td><td>29</td><td>5.9</td><td>4.5</td><td>4.5</td><td>0.2</td><td>15.0</td></tr>
<tr><td>Qam8</td>
<td>128</td><td>30</td><td>4.9</td><td>1.1</td><td>4.5</td><td>0.2</td><td>10.8</td></tr>
<tr><td>Qam9</td>
<td>144</td><td>31</td><td>4.4</td><td>4.4</td><td>4.5</td><td>0.3</td><td>13.7</td></tr>
<tr><td>Qam10</td>
<td>160</td><td>32</td><td>8.4</td><td>5.0</td><td>8.8</td><td>0.2</td><td>22.3</td></tr>
<tr><td>Qam11</td>
<td>176</td><td>OFF</td><td>0.0</td><td>0.0</td><td>0.0</td><td>0.0</td><td>0.0</td></tr>
<tr><td>Qam12</td>
<td>192</td><td>OFF</td><td>0.0</td><td>0.0</td><td>0.0</td><td>0.0</td><td>0.0</td></tr>
<tr><td>Total</td><td></td><td></td><td></td><td></td><td></td><td></td><td>182.8</td></tr></table>
<h2>Control</h2>chassisId = 1, hwVersion = 0.16, swVersion = 1.11.9, tempC = 40
MAC = c4:27:95:98:ed:eb, licenseCount = 10
<form method=\'get\' action=\'/cgi-bin/webcmd\'><pre><input type=\'hidden\' name=\'screen\' value=\'qamControlWrite\'><input type=\'hidden\' name=\'qamIp\' value=\'192.168.6.2\'><input type=\'hidden\' name=\'modulationMode\' value=\'1\'><input type=\'hidden\' name=\'qamMode\' value=\'4\'>baseChannel: A=<input type=\'text\' name=\'baseChannel0\' value=\'23\' size=\'3\'> B=<input type=\'text\' name=\'baseChannel1\' value=\'27\' size=\'3\'> C=<input type=\'text\' name=\'baseChannel2\' value=\'31\' size=\'3\'>
<input type=\'hidden\' name=\'strengthPercent0\' value=\'95\' size=\'3\'><input type=\'hidden\' name=\'strengthPercent1\' value=\'95\' size=\'3\'><input type=\'hidden\' name=\'strengthPercent2\' value=\'95\' size=\'3\'>carrierOn: A=<input type=\'text\' name=\'carrierOn0\' value=\'1\' size=\'1\'><input type=\'text\' name=\'carrierOn1\' value=\'1\' size=\'1\'><input type=\'text\' name=\'carrierOn2\' value=\'1\' size=\'1\'><input type=\'text\' name=\'carrierOn3\' value=\'1\' size=\'1\'> B=<input type=\'text\' name=\'carrierOn4\' value=\'1\' size=\'1\'><input type=\'text\' name=\'carrierOn5\' value=\'1\' size=\'1\'><input type=\'text\' name=\'carrierOn6\' value=\'1\' size=\'1\'><input type=\'text\' name=\'carrierOn7\' value=\'1\' size=\'1\'> C=<input type=\'text\' name=\'carrierOn8\' value=\'1\' size=\'1\'><input type=\'text\' name=\'carrierOn9\' value=\'1\' size=\'1\'><input type=\'text\' name=\'carrierOn10\' value=\'0\' size=\'1\'><input type=\'text\' name=\'carrierOn11\' value=\'0\' size=\'1\'>
alternateIp: <input type=\'text\' name=\'alternateIp\' value=\'192.168.6.99\'>
<input type=\'hidden\' name=\'macAddress\' value=\'c4:27:95:98:ed:eb\'>tftpIp: <input type=\'text\' name=\'tftpIp\' value=\'192.168.100.3\'>
tftpFilename: <input type=\'text\' name=\'tftpFilename\' value=\'\' size=\'60\'>
reset: <input type=\'text\' name=\'reset\' value=\'0\'>
<input type=\'submit\'>
</pre></form>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);