$re = '/([\s\S]*?)(_swft-)/m';
$str = '5152287-001_17SI1039.01_BASE_swft-105173.xml';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);