$re = '/^(\+?\d{1,3})\s\d{10}$/';
$str = '+1297899859038';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);