re = /((?:\d*\.\d+)|(?:\d|[1-9]\d+))(?:[fF])/
str = 'Welcome to RegExr v2.0 by gskinner.com!
Edit the Expression & Text to see matches. Roll over matches or the expression for details. Undo mistakes with ctrl-z. Save & Share expressions with friends or the Community. A 1f full Reference & Help is available in 123l the Library, or watch the video Tutorial.
123.2L 3f .4f .454545F
Sample text for testing:
abcdefghijklmnopqrstuvwxyz ABCDEFGHIJKLMNOPQRSTUVWXYZ
0123456789 +-.,!@#$%^&*();\\/|<>"\'
12345 -98.7 3.141 .6180 9,000 +42
555.123.4567 +1-(800)-555-2468
foo@demo.net bar.ba@test.co.uk
www.demo.com http://foo.co.uk/
http://regexr.com/foo.html?q=bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end