#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:4[0-9]{12}(?:[0-9]{3})?|5[1-5][0-9]{14}|3[47][0-9]{13}|3(?:0[0-5]|[68][0-9])[0-9]{11}|6(?:011|5[0-9]{2})[0-9]{12}|(?:2131|1800|35\d{3})\d{11})$"
Local $sString = "4242424242424242" & @CRLF & _
"4012888888881881" & @CRLF & _
"4000056655665556" & @CRLF & _
"5555555555554444" & @CRLF & _
"5200828282828210" & @CRLF & _
"5105105105105100" & @CRLF & _
"378282246310005" & @CRLF & _
"371449635398431" & @CRLF & _
"6011111111111117" & @CRLF & _
"6011000990139424" & @CRLF & _
"30569309025904" & @CRLF & _
"38520000023237" & @CRLF & _
"3530111333300000" & @CRLF & _
"3566002020360505" & @CRLF & _
"8942424242424242" & @CRLF & _
"63942424242" & @CRLF & _
"445299295665920" & @CRLF & _
"" & @CRLF & _
"Visa" & @CRLF & _
"Visa" & @CRLF & _
"Visa (debit)" & @CRLF & _
"MasterCard" & @CRLF & _
"MasterCard (debit)" & @CRLF & _
"MasterCard (prepaid)" & @CRLF & _
"American Express" & @CRLF & _
"American Express" & @CRLF & _
"Discover" & @CRLF & _
"Discover" & @CRLF & _
"Diners Club" & @CRLF & _
"Diners Club" & @CRLF & _
"JCB" & @CRLF & _
"JCB" & @CRLF & _
"Invalid" & @CRLF & _
"Invalid" & @CRLF & _
"Invalid"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")