// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([A-Za-z]+)\s([A-Za-z]+)\s([A-Z]{2})\s([0-9]+)\s([A-Za-z]+)(\s+)([A-Z])\s([0-9]{1,2})\/([0-9]{1,2})\/([0-9]{4}\s)([0-9]{1,2}):([0-9]{1,2})\s").unwrap();
let string = "Frankfurt Izmir XQ 971 SunEco A 13/03/2016 14:55 AINT9 HK 30
Izmir Trabzon XQ 9270 SunEco S 13/03/2016 20:10 SADDOND HK 30
Trabzon Antalya XQ 7619 SunEco S 31/03/2016 12:00 SADDOND HK 30
Antalya Frankfurt XQ 140 SunEco Z 31/03/2016 15:00 ZINT8 HK 30";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}