$re = '/^[a-zA-Z0-9\_]+$/';
$str = 'hola_jdSd930384Sjd_';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);