$re = '/^([A-Z][a-z]*(\s+[A-Z][a-z]*))$/';
$str = 'Desk Desk';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);