#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)<PNR>([\w]+)<\/PNR>" & @CRLF & _
""
Local $sString = "<?xml version="1.0" encoding="UTF-8" standalone="yes"?>" & @CRLF & _
"<EGE_Booking>" & @CRLF & _
" <TripID>1004-3637-360</TripID>" & @CRLF & _
" <RecordLocator>1004-3637-360</RecordLocator>" & @CRLF & _
" <Travelers>" & @CRLF & _
" <Traveler>" & @CRLF & _
" <PerCode>13593199</PerCode>" & @CRLF & _
" <FirstName>Claude</FirstName>" & @CRLF & _
" <LastName>Christensson</LastName>" & @CRLF & _
" <ContactDetails>" & @CRLF & _
" <Email>claude.christensson@wirelesscar.com</Email>" & @CRLF & _
" <MobilePhone>46765537005</MobilePhone>" & @CRLF & _
" </ContactDetails>" & @CRLF & _
" <TravellerCostCenter>" & @CRLF & _
" <CostCenter Code="CC3">" & @CRLF & _
" <Label>Employee ID</Label>" & @CRLF & _
" <Value>56524</Value>" & @CRLF & _
" </CostCenter>" & @CRLF & _
" <CostCenter Code="CC4">" & @CRLF & _
" <Label>Global Department code</Label>" & @CRLF & _
" <Value>DI43400</Value>" & @CRLF & _
" </CostCenter>" & @CRLF & _
" </TravellerCostCenter>" & @CRLF & _
" </Traveler>" & @CRLF & _
" </Travelers>" & @CRLF & _
" <Segments>" & @CRLF & _
" <HotelSegment>" & @CRLF & _
" <HOTEL>" & @CRLF & _
" <TripItemID>5a7dc8f971ac0163f7563e7e</TripItemID>" & @CRLF & _
" <PNR>ABC1DS</PNR>" & @CRLF & _
" <Status>V</Status>" & @CRLF & _
" <CheckInDate>2018-02-13</CheckInDate>" & @CRLF & _
" <CheckOutDate>2018-02-14</CheckOutDate>" & @CRLF & _
" <Vendor SupplierType="11281422">Genting Hotel</Vendor>" & @CRLF & _
" <PropertyName>Genting Hotel</PropertyName>" & @CRLF & _
" <Location>" & @CRLF & _
" <Name>Pendigo Way, England, B40 1PU</Name>" & @CRLF & _
" <City>Birmingham</City>" & @CRLF & _
" <Country Code="GBR">Storbritannien</Country>" & @CRLF & _
" </Location>" & @CRLF & _
" <ConfirmationCode>982674693</ConfirmationCode>" & @CRLF & _
" <Cost>" & @CRLF & _
" <Amount>751.08</Amount>" & @CRLF & _
" <Currency Code="SEK">Swedish Krona</Currency>" & @CRLF & _
" </Cost>" & @CRLF & _
" <OutOfPolicyReasons/>" & @CRLF & _
" </HOTEL>" & @CRLF & _
" <HOTEL>" & @CRLF & _
" <TripItemID>5a7dc8f971ac0163f7563e7e</TripItemID>" & @CRLF & _
" <PNR>55545261643</PNR>" & @CRLF & _
" <Status>V</Status>" & @CRLF & _
" <CheckInDate>2018-02-13</CheckInDate>" & @CRLF & _
" <CheckOutDate>2018-02-14</CheckOutDate>" & @CRLF & _
" <Vendor SupplierType="11281422">Genting Hotel</Vendor>" & @CRLF & _
" <PropertyName>Genting Hotel</PropertyName>" & @CRLF & _
" <Location>" & @CRLF & _
" <Name>Pendigo Way, England, B40 1PU</Name>" & @CRLF & _
" <City>Birmingham</City>" & @CRLF & _
" <Country Code="GBR">Storbritannien</Country>" & @CRLF & _
" </Location>" & @CRLF & _
" <ConfirmationCode>982674693</ConfirmationCode>" & @CRLF & _
" <Cost>" & @CRLF & _
" <Amount>751.08</Amount>" & @CRLF & _
" <Currency Code="SEK">Swedish Krona</Currency>" & @CRLF & _
" </Cost>" & @CRLF & _
" <OutOfPolicyReasons/>" & @CRLF & _
" </HOTEL>" & @CRLF & _
" </HotelSegment>" & @CRLF & _
" </Segments>" & @CRLF & _
" <Invoicing>" & @CRLF & _
" <CompanyCode>28781</CompanyCode>" & @CRLF & _
" <ClientNumber>28781</ClientNumber>" & @CRLF & _
" <ClientRequisition>claude.christensson@wirelesscar.com</ClientRequisition>" & @CRLF & _
" <ClientReference>689100277</ClientReference>" & @CRLF & _
" <ClientCostCenter>" & @CRLF & _
" <CostCenter Code="CC1">" & @CRLF & _
" <Label>Legal Entity</Label>" & @CRLF & _
" <Value>WirelessCar Sweden AB</Value>" & @CRLF & _
" </CostCenter>" & @CRLF & _
" <CostCenter Code="CC2">" & @CRLF & _
" <Label>Cost Center</Label>" & @CRLF & _
" <Value>989502</Value>" & @CRLF & _
" </CostCenter>" & @CRLF & _
" </ClientCostCenter>" & @CRLF & _
" </Invoicing>" & @CRLF & _
"</EGE_Booking>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")