$re = '/begin((?!word1|word2).)*end/m';
$str = 'begin word2 end
begin bla end
begin word1 end
begin bla end';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);