re = /(?i)^(?<datetime>[^\s]+)(?:[\s]*)[^\t\n]*\tVendorID(?<VendorID>\d+)(?:[\s]*)[^\t\n]*\tCode=(?<Code>[]+)(?:[\w]*)[^\t\n]*\tAcctID-(?<AcctId>[]+)(?:[\w]*)[^\t\n]*\tProductName.(?<ProductName>:"\w+\s+\d+\w+\s+\d+'\s+\w+\s+\w+"|"\w+\s+\w+"|"\w+\s+\w+\s+\w+\s+\d+'"|"\w+-\d+GB"|"\w+\s+\w+\s+\d+\s+\w+")\sPurchasePrice-(?<PurchasePrice>[^\s]+)/
str = '[01/Dec/2017*04*18*21] VendorID9107 Code=K AcctID-8953037315467146 ProductName*"Kindle-20GB" PurchasePrice-99.95
[01/Dec/2017*04*19*28] VendorID1228 Code=B AcctID-7837012624465602 ProductName*"Kindle-20GB" PurchasePrice-99.95
[01/Dec/2017*04*22*25] VendorID1068 Code=N AcctID-9709871243642418 ProductName*"ATT iPhone" PurchasePrice-109.95
[01/Dec/2017*04*23*23] VendorID1290 Code=A AcctID-3450813992517607 ProductName*"Kindle-10GB" PurchasePrice-75.95
[01/Dec/2017*04*24*23] VendorID1269 Code=F AcctID-1489312718144625 ProductName*"Kindle-20GB" PurchasePrice-99.95
[01/Dec/2017*04*26*18] VendorID3100 Code=H AcctID-9716406082508710 ProductName*"ATT iPhone" PurchasePrice-109.95
[01/Dec/2017*04*27*14] VendorID1017 Code=D AcctID-3083306333747239 ProductName*"Kindle-10GB" PurchasePrice-75.95
[01/Dec/2017*04*29*16] VendorID5032 Code=K AcctID-4276195430043043 ProductName*"Kindle-20GB" PurchasePrice-99.95
[01/Dec/2017*04*31*02] VendorID1299 Code=L AcctID-8996052682970456 ProductName*"ATT iPhone" PurchasePrice-109.95
[01/Dec/2017*04*31*20] VendorID1093 Code=B AcctID-5542734063460327 ProductName*"Kindle-10GB" PurchasePrice-75.95
[01/Dec/2017*04*32*29] VendorID1136 Code=I AcctID-2161341760512161 ProductName*"Kindle-20GB" PurchasePrice-99.95
[01/Dec/2017*04*33*08] VendorID1295 Code=H AcctID-4492310716853035 ProductName*"ATT iPhone" PurchasePrice-109.95
[01/Dec/2017*04*34*17] VendorID1259 Code=F AcctID-6025810834147335 ProductName*"Kindle-10GB" PurchasePrice-75.95
[01/Dec/2017*04*35*50] VendorID5007 Code=A AcctID-4143436807109335 ProductName*"Kindle-20GB" PurchasePrice-99.95
[01/Dec/2017*04*37*04] VendorID5012 Code=E AcctID-5836421701410558 ProductName*"ATT iPhone" PurchasePrice-109.95
[01/Dec/2017*04*38*33] VendorID1255 Code=D AcctID-2858094855870282 ProductName*"ATT iPad" PurchasePrice-119.00
[01/Dec/2017*04*41*28] VendorID5041 Code=G AcctID-6644161728834130 ProductName*"ATT iPad" PurchasePrice-119.00
[01/Dec/2017*04*41*06] VendorID6020 Code=L AcctID-1194456434790706 ProductName*"Panasonic Phone" PurchasePrice-19.95
[01/Dec/2017*04*44*22] VendorID1168 Code=B AcctID-2140880889694760 ProductName*"ATT iPad" PurchasePrice-119.00
[01/Dec/2017*04*44*28] VendorID5017 Code=J AcctID-6828056071845753 ProductName*"ATT iPad" PurchasePrice-119.00
[01/Dec/2017*04*46*27] VendorID7020 Code=M AcctID-1207953506059973 ProductName*"Kindle-5GB" PurchasePrice-39.95
[01/Dec/2017*04*47*27] VendorID1018 Code=L AcctID-1814996571531289 ProductName*"Sony 4K 55\' LED TV" PurchasePrice-1019.99
[01/Dec/2017*04*49*43] VendorID1106 Code=H AcctID-5144898866665112 ProductName*"Sony 4K 55\' LED TV" PurchasePrice-1019.99
[01/Dec/2017*04*50*19] VendorID9100 Code=H AcctID-9417281735074121 ProductName*"Panasonic Phone" PurchasePrice-19.95
[01/Dec/2017*04*51*55] VendorID5065 Code=I AcctID-6160910972630902 ProductName*"ATT iPad" PurchasePrice-119.00
[01/Dec/2017*04*52*31] VendorID9116 Code=K AcctID-3766667203359925 ProductName*"Sony 4K 55\' LED TV" PurchasePrice-1019.99
[01/Dec/2017*04*54*52] VendorID3109 Code=C AcctID-7828078694639559 ProductName*"Sony 4K 55\' LED TV" PurchasePrice-1019.99
[01/Dec/2017*04*55*26] VendorID1127 Code=F AcctID-1603448096979053 ProductName*"ATT iPad" PurchasePrice-119.00
[01/Dec/2017*04*57*28] VendorID1163 Code=B AcctID-9647570510597869 ProductName*"Sony 4K 55\' LED TV" PurchasePrice-1019.99
[01/Dec/2017*04*59*51] VendorID6039 Code=N AcctID-7764674863234370 ProductName*"Panasonic Phone" PurchasePrice-19.95
[01/Dec/2017*05*00*38] VendorID1285 Code=G AcctID-3005385689787769 ProductName*"Sony 4K 55\' LED TV" PurchasePrice-1019.99
[01/Dec/2017*05*02*30] VendorID1020 Code=L AcctID-7862782905297066 ProductName*"ATT iPad" PurchasePrice-119.00
[01/Dec/2017*05*02*34] VendorID1203 Code=B AcctID-2366487309577294 ProductName*"ATT iPad" PurchasePrice-119.00
[01/Dec/2017*05*05*39] VendorID9105 Code=A AcctID-7095388791856370 ProductName*"Panasonic Phone" PurchasePrice-19.95
[01/Dec/2017*05*05*31] VendorID5030 Code=L AcctID-7363535777973243 ProductName*"Dewalt Table Saw 12\'" PurchasePrice-319.99
[01/Dec/2017*05*06*30] VendorID5028 Code=A AcctID-8320885359958183 ProductName*"Dewalt Table Saw 10\'" PurchasePrice-219.99
[01/Dec/2017*05*09*19] VendorID3100 Code=A AcctID-6278944692738174 ProductName*"Dewalt Mitre Saw 10\'" PurchasePrice-279.99
[01/Dec/2017*05*10*27] VendorID1208 Code=D AcctID-5679598522849555 ProductName*"Skil Mitre Saw 10\'" PurchasePrice-89.99
[01/Dec/2017*05*11*01] VendorID1130 Code=F AcctID-5371210347579883 ProductName*"Skil Table Saw 12\'" PurchasePrice-199.99
[01/Dec/2017*05*12*56] VendorID1035 Code=A AcctID-3951568282123336 ProductName*"Panasonic Phone" PurchasePrice-19.95
[01/Dec/2017*05*14*23] VendorID5027 Code=A AcctID-7369295495740645 ProductName*"Dewalt Table Saw 12\'" PurchasePrice-319.99
[01/Dec/2017*05*15*18] VendorID1114 Code=E AcctID-6653798756713612 ProductName*"Dewalt Table Saw 10\'" PurchasePrice-219.99
[01/Dec/2017*05*17*25] VendorID1079 Code=M AcctID-8243721800994796 ProductName*"Dewalt Mitre Saw 10\'" PurchasePrice-279.99
[01/Dec/2017*05*17*44] VendorID1004 Code=K AcctID-8278531894986091 ProductName*"Skil Mitre Saw 10\'" PurchasePrice-89.99
[01/Dec/2017*05*19*56] VendorID1032 Code=B AcctID-2418000340794179 ProductName*"Skil Table Saw 12\'" PurchasePrice-199.99
[01/Dec/2017*05*21*53] VendorID5028 Code=J AcctID-6119225511514535 ProductName*"Panasonic Phone" PurchasePrice-19.95
[01/Dec/2017*05*22*35] VendorID1109 Code=B AcctID-9413707917106760 ProductName*"Dewalt Table Saw 12\'" PurchasePrice-319.99
[01/Dec/2017*05*24*05] VendorID1005 Code=L AcctID-3220578398962419 ProductName*"Dewalt Table Saw 10\'" PurchasePrice-219.99
[01/Dec/2017*05*26*31] VendorID1073 Code=L AcctID-7069027907726146 ProductName*"Dewalt Mitre Saw 10\'" PurchasePrice-279.99
[01/Dec/2017*05*26*35] VendorID1247 Code=J AcctID-6917608079956369 ProductName*"Skil Mitre Saw 10\'" PurchasePrice-89.99
[01/Dec/2017*05*28*40] VendorID1106 Code=C AcctID-7198567189050356 ProductName*"Skil Table Saw 12\'" PurchasePrice-199.99
[01/Dec/2017*05*31*09] VendorID5060 Code=J AcctID-4332095600750836 ProductName*"Panasonic Phone" PurchasePrice-19.95
[01/Dec/2017*05*31*38] VendorID1133 Code=A AcctID-1615631383326043 ProductName*"Dewalt Table Saw 12\'" PurchasePrice-319.99
[01/Dec/2017*05*32*26] VendorID1130 Code=J AcctID-9181431156382922 ProductName*"Dewalt Table Saw 10\'" PurchasePrice-219.99
[01/Dec/2017*05*34*46] VendorID1161 Code=F AcctID-4392344048365871 ProductName*"Dewalt Mitre Saw 10\'" PurchasePrice-279.99
[01/Dec/2017*05*36*23] VendorID4113 Code=H AcctID-3709002216706315 ProductName*"Skil Mitre Saw 10\'" PurchasePrice-89.99
[01/Dec/2017*05*37*57] VendorID1255 Code=B AcctID-7414393428359645 ProductName*"Skil Table Saw 12\'" PurchasePrice-199.99
[01/Dec/2017*05*38*44] VendorID1110 Code=L AcctID-2629054172606980 ProductName*"Panasonic Phone" PurchasePrice-19.95
[01/Dec/2017*05*40*19] VendorID1181 Code=F AcctID-8631474948451678 ProductName*"Dewalt Table Saw 12\'" PurchasePrice-319.99
[01/Dec/2017*05*41*55] VendorID5012 Code=H AcctID-4336650277364261 ProductName*"Dewalt Table Saw 10\'" PurchasePrice-219.99
[01/Dec/2017*05*42*58] VendorID3111 Code=I AcctID-5562485846159442 ProductName*"Dewalt Mitre Saw 10\'" PurchasePrice-279.99
[01/Dec/2017*05*44*46] VendorID1262 Code=H AcctID-7478676667150845 ProductName*"Skil Mitre Saw 10\'" PurchasePrice-89.99
[01/Dec/2017*05*46*23] VendorID1215 Code=E AcctID-1755167636424251 ProductName*"Skil Table Saw 12\'" PurchasePrice-199.99
[01/Dec/2017*05*46*54] VendorID1082 Code=M AcctID-2770775272203822 ProductName*"Samsung Note3" PurchasePrice-199.99
[01/Dec/2017*05*48*45] VendorID1159 Code=D AcctID-9964901163234349 ProductName*"Samsung Note4" PurchasePrice-409.99
[01/Dec/2017*05*49*14] VendorID7023 Code=B AcctID-1159928085233110 ProductName*"Kindle-5GB" PurchasePrice-39.95
[01/Dec/2017*05*51*35] VendorID7045 Code=A AcctID-4377989337674393 ProductName*"Kindle-5GB" PurchasePrice-39.95
[01/Dec/2017*05*53*54] VendorID1118 Code=E AcctID-1195137030279408 ProductName*"Samsung Note3" PurchasePrice-199.99
[01/Dec/2017*05*55*06] VendorID6022 Code=F AcctID-2448359258401870 ProductName*"Samsung Note4" PurchasePrice-409.99
[01/Dec/2017*05*54*51] VendorID1107 Code=F AcctID-2683282761033502 ProductName*"Samsung Note 2 Curve" PurchasePrice-199.99
[01/Dec/2017*05*57*21] VendorID1253 Code=F AcctID-6420171533049326 ProductName*"Samsung Note3" PurchasePrice-199.99
[01/Dec/2017*05*58*33] VendorID1157 Code=F AcctID-2782649436589508 ProductName*"Samsung Note4" PurchasePrice-409.99
[01/Dec/2017*06*00*24] VendorID4112 Code=A AcctID-8745631588051601 ProductName*"Samsung Note 2 Curve" PurchasePrice-199.99
[01/Dec/2017*06*00*53] VendorID1293 Code=N AcctID-5130858182116048 ProductName*"Samsung Note3" PurchasePrice-199.99
[01/Dec/2017*06*02*21] VendorID4114 Code=A AcctID-7818194472354211 ProductName*"Samsung Note4" PurchasePrice-409.99
[01/Dec/2017*06*05*20] VendorID1169 Code=D AcctID-9723087970112499 ProductName*"Samsung Note 2 Curve" PurchasePrice-199.99
[01/Dec/2017*06*06*00] VendorID1153 Code=D AcctID-2999756939309052 ProductName*"Dewalt Table Saw 12\'" PurchasePrice-319.99
[01/Dec/2017*06*08*08] VendorID7040 Code=B AcctID-9503561157966610 ProductName*"Dewalt Table Saw 10\'" PurchasePrice-219.99
[01/Dec/2017*06*08*14] VendorID5024 Code=A AcctID-7887221613830284 ProductName*"Dewalt Mitre Saw 10\'" PurchasePrice-279.99
[01/Dec/2017*06*10*56] VendorID1018 Code=A AcctID-2606727281939422 ProductName*"Skil Mitre Saw 10\'" PurchasePrice-89.99
[01/Dec/2017*06*13*03] VendorID7014 Code=N AcctID-2304631319411251 ProductName*"Skil Table Saw 12\'" PurchasePrice-199.99
[01/Dec/2017*06*14*18] VendorID1019 Code=F AcctID-9158030313596905 ProductName*"Samsung Note3" PurchasePrice-199.99
[01/Dec/2017*06*14*52] VendorID5054 Code=B AcctID-4097455553831334 ProductName*"Samsung Note4" PurchasePrice-409.99
[01/Dec/2017*06*16*10] VendorID5031 Code=B AcctID-6399486197314115 ProductName*"Kindle-5GB" PurchasePrice-39.95
[01/Dec/2017*06*17*56] VendorID1006 Code=I AcctID-8453338407642163 ProductName*"Kindle-5GB" PurchasePrice-39.95
[01/Dec/2017*06*18*17] VendorID1066 Code=B AcctID-7672364158790967 ProductName*"Samsung Note3" PurchasePrice-199.99
[01/Dec/2017*06*19*48] VendorID1093 Code=H AcctID-3626437621256567 ProductName*"Samsung Note4" PurchasePrice-409.99
[01/Dec/2017*06*22*11] VendorID1019 Code=N AcctID-7379411573056991 ProductName*"Samsung Note 2 Curve" PurchasePrice-199.99
[01/Dec/2017*06*22*32] VendorID1113 Code=L AcctID-2878864974834874 ProductName*"Samsung Note3" PurchasePrice-199.99
[01/Dec/2017*06*24*44] VendorID1108 Code=J AcctID-2917759876060974 ProductName*"Samsung Note4" PurchasePrice-409.99
[01/Dec/2017*06*24*54] VendorID1290 Code=D AcctID-2530238018724709 ProductName*"Samsung Note 2 Curve" PurchasePrice-199.99
[01/Dec/2017*06*26*37] VendorID1107 Code=E AcctID-5593723070091395 ProductName*"Samsung Note3" PurchasePrice-199.99
[01/Dec/2017*06*27*31] VendorID9110 Code=I AcctID-4822826820447706 ProductName*"Samsung Note4" PurchasePrice-409.99
[01/Dec/2017*06*29*18] VendorID5021 Code=C AcctID-8315933182750022 ProductName*"Samsung Note 2 Curve" PurchasePrice-199.99
[01/Dec/2017*06*30*25] VendorID7003 Code=D AcctID-7644882064312006 ProductName*"Sony 4K 55\' LED TV" PurchasePrice-1019.99
[01/Dec/2017*06*33*21] VendorID1251 Code=A AcctID-5168276979639643 ProductName*"Sony 4K 55\' LED TV" PurchasePrice-1019.99
[01/Dec/2017*06*34*15] VendorID1235 Code=B AcctID-6528545551507327 ProductName*"Sony 4K 55\' LED TV" PurchasePrice-1019.99
[01/Dec/2017*06*35*15] VendorID9112 Code=C AcctID-6754259683614078 ProductName*"Sony 4K 55\' LED TV" PurchasePrice-1019.99
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end