# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(8|\+7)\s*\(*\d+\)*\s*\d+\-*\d+\-*\d+\-*\s*\(*\w+\.*\s*\d+\)*"
test_str = ("lastname,firstname,surname,organization,position,phone,email\n"
"Усольцев Олег Валентинович,,,ФНС,главный специалист – эксперт отдела взаимодействия с федеральными органами власти Управления налогообложения имущества и доходов физических лиц,+7 (495) 913-04-78,opendata@nalog.ru\n"
"Мартиняхин Виталий Геннадьевич,,,ФНС,,+74959130037,\n"
"Наркаев,Вячеслав Рифхатович,,ФНС,,8 495-913-0168,\n"
"Мартиняхин,Виталий,Геннадьевич,ФНС,cоветник отдела Интернет проектов Управления информационных технологий,,,\n"
"Лукина Ольга Владимировна,,,Минфин,,+7 (495) 983-36-99 доб. 2926,Olga.Lukina@minfin.ru\n"
"Паньшин Алексей Владимирович,,,Минфин,,8(495)748-49-73,1248@minfin.ru\n"
"Лагунцов Иван Алексеевич,,,Минфин,,+7 (495) 913-11-11 (доб. 0792),\n"
"Лагунцов Иван,,,,,,Ivan.Laguntcov@minfin.ru")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.