use strict;
my $str = 'Feb 27 16:41:39 10.128.5.5 tc-cl-wlc01: *apfReceiveTask: Feb 27 16:41:38.944: %APF-3-NO_FRAMED_IP_ADDRESS: [PA]apf_radius.c:2456 \'AcctStop\' clt MAC: 14:32:d1:c9:43:58 AP MAC: c0:25:5c:60:ab:f0 Role \'Local\' PemState \'START\' SSID \'CPS\' Connected for \'126\' secs';
my $regex = qr/^([^\s]+)\s([^\s]+)\s([^\s]+)\s([^\s]+)\s+(?<server>[^\s]+)\s+\*(?<task>[^\s]+\:)\s+([^\s]+)\s+([^\s]+)\s+([^\s]+)\s+\%(?<status>[^\s]+)\s+(?<task1>[^\s]+)\s+(?<action>[^\s]+\')\s+\w+\s+\w+\:\s+(?<src_mac>[^\s]+)\s+\w+\s+\w+\:\s+(?<dest_mac>[^\s]+)\s+\w+\s\'\w+\'\s+(?<tast2>)\w+\s+\'(?<action2>[^\s]+)\s+\w+\s+\'\w+\'\s+\w+\s+\w+\s+\'(?<timesec>[^\s]+)\s+\w+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}