const regex = /([0-9]{3}[.-]?[0-9]{3,4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9]{3}[.-]?[0-9]{3,4})', 'gm')
const str = `This is my MAC 412.346.8021
Hey my number is +1(903)509-1123. Give me a call`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}