$re = '/^([0-9]{1,3}[\.\-\s]??){5}$/m';
$str = '3 234 345 567
14-24-35-40-33
5322527992
3.123-123 123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);