package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(https?:\/\/)((?:[-a-zA-Z0-9@:%._+~#=]+)\.)?([-a-zA-Z0-9@:%._+~#=]{2,256}\.[a-z]{2,6}\b|localhost(?:\:\d{1,5})?)(\/[\w.-]*)*(\?[\w\-._~!*'(),%=&+]*)?($|\#.*|\?.*)?`)
var str = `https://www.google.com/search?q=define+inherently&oq=&gs_lcrp=EgZjaHJvbWUqBggCEEUYOzIGCAAQRRg5Mg4IARBFGCcYOxiABBiKBTIGCAIQRRg7Mg8IAxAAGEMYyQMYgAQYigUyDAgEEAAYQxiABBiKBTIMCAUQABhDGIAEGIoFMg0IBhAAGJIDGIAEGIoFMg0IBxAAGJIDGIAEGIoFMgcICBAAGIAEMgcICRAAGI8C0gEJNjY1MGowajE1qAIAsAIA&sourceid=chrome&ie=UTF-8#shebang`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}