$re = '/^[0-9\+\-\(\)\s]{1,19}$/i';
$str = '89514555))+-';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);