$re = '/([01][0-9]|[2][0-3]):([0-5][0-9])/';
$str = '12:59';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);