$re = '/\b[^\d\W]+\b/';
$str = 'abalbal asldad 23mg sadaskld 3123 adasdas';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);