const regex = /[A-Z]{2}\d[A-Z] \d[A-Z]{2}/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Z]{2}\\d[A-Z] \\d[A-Z]{2}', 'i')
const str = `WC1E 7BT`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}