// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)[NMS]\w+\-\w*BASE\w*\.AD\.DTI").unwrap();
let string = "MAVM-WLBASE1a.ad.dti.
MAVM-WLBASE2a.ad.dti.
MAVM-WLBASE3a.ad.dti.
MAVM-WLBASE4a.ad.dti.
MAVM-WLBASE5a.ad.dti.
NJ-BASEQA2015.ad.dti.
NJVM-BASEQA2014.ad.dti.
NJVM-WLBASE6b.ad.dti.
NJVM-WLBASE7a.ad.dti.
NY2-BASEQA.ad.dti.
NY2-DW5BASEQA01.ad.dti.
SHVM-WLBASE1A.ad.dti.
NJ-ODEV2015.ad.dti.
NJ-ODEV2015b.ad.dti.
NJVM-ODEV2014.ad.dti.
NY2-ODEV2017.ad.dti.
SH-ODEV2017.ad.dti.
MOVM-WL12C.ad.dti.
NJ-PASWL12c01.ad.dti.
NJ-WL12cSVT01.ad.dti.
NJVM-WL12CUST1.ad.dti.
NJVM-wl12cust2.ad.dti.
njvm-wl12cust4.ad.dti.
njvm-wl12x64j7a.ad.dti.
NY2-WL12asp01.ad.dti.
NY2-WL12ASP02.ad.dti.
NY2-WL12ASP03.ad.dti.
NY2-WL12ASP04.ad.dti.
SH-AutoITWL12.ad.dti.
SH-PASWL12c02.ad.dti.
SHVM-WL12-RE.ad.dti.
SHVM-WL12CUST3.ad.dti.
ASP-WL1213INT01.asp.ad.dti.
ASP-WL12CEXT5.asp.ad.dti.
ASPVM-WL12c10.asp.ad.dti.
ASPVM-WL12c8.asp.ad.dti.
ASPVM-WL12c9.asp.ad.dti.
LT-MPROEKT.ad.dti.
LT-jpo01.ad.dti
LT-jpo01.adXdti";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}