re = /^(?!BG|GB|KN|NK|NT|TN|ZZ)[^DFIQUV][^DFIQUVo][0-9]{6}[ABCD]$/im
str = 'BG283902A
AD283902A
AO283902A
AA283902Z
AA283902A'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end