$re = '/(<a(?:(?!\/a>).|\n)*(?=\>).)(.+)(<\/a>)/i';
$str = '<a href="http://">Text</a>
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);