#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((^0)\s+|(^1)\s+|(^2)\s+|(^3)\s+|(^4)\s+|(^5)\s+)((((.{4})(.+)))|((.{4})))"
Local $sString = "0 @I0066@ INDI" & @CRLF & _
"1 NAME Joan Adrienne /Hatch/" & @CRLF & _
"2 GIVN Joan Adrienne" & @CRLF & _
"2 SURN Hatch" & @CRLF & _
"2 SOUR @S0045@" & @CRLF & _
"3 DATA" & @CRLF & _
"4 TEXT Birth date: 30 May 1935 Birth place: Hennepin, Minnesota" & @CRLF & _
"2 SOUR @S0131@" & @CRLF & _
"3 PAGE Source Citation: Year: 1940; Census Place: Faribault, Rice, Minnesota; Roll: T627_1953; Page: 8B; Enumeration District: 66-9A" & @CRLF & _
"3 DATA" & @CRLF & _
"4 TEXT residence date: 1 Apr 1940 residence place: Faribault, Rice, Minnesot" & @CRLF & _
"5 CONC a, United States birth date: May 30, 1935 birth place: Minneapolis" & @CRLF & _
"5 CONC , Hennepin, Minnesota, USA Name: Joan Adrienne Hatch" & @CRLF & _
"3 NOTE @N0121@" & @CRLF & _
"2 SOUR @S0635@" & @CRLF & _
"3 DATA" & @CRLF & _
"4 TEXT Marriage date: 29 Dec 1953 Marriage place: Cook County, IL" & @CRLF & _
"1 SEX F" & @CRLF & _
"1 BIRT" & @CRLF & _
"2 DATE 30 MAY 1935" & @CRLF & _
"2 PLAC Minneapolis, Hennepin, Minnesota, USA" & @CRLF & _
"2 SOUR @S0045@" & @CRLF & _
"3 DATA" & @CRLF & _
"4 TEXT Birth date: 30 May 1935 Birth place: Hennepin, Minnesota" & @CRLF & _
"2 SOUR @S0131@" & @CRLF & _
"3 PAGE Source Citation: Year: 1940; Census Place: Faribault, Rice, Minnesota; Roll: T627_1953; Page: 8B; Enumeration District: 66-9A" & @CRLF & _
"3 DATA" & @CRLF & _
"4 TEXT residence date: 1 Apr 1940 residence place: Faribault, Rice, Minnesot" & @CRLF & _
"5 CONC a, United States birth date: May 30, 1935 birth place: Minneapolis" & @CRLF & _
"5 CONC , Hennepin, Minnesota, USA Name: Joan Adrienne Hatch" & @CRLF & _
"3 NOTE @N0125@" & @CRLF & _
"1 DEAT" & @CRLF & _
"2 DATE 14 DEC 1989" & @CRLF & _
"2 PLAC Nyack, Rockland, New York, USA" & @CRLF & _
"1 RESI" & @CRLF & _
"2 DATE 1 APR 1940" & @CRLF & _
"2 PLAC Faribault, Rice, Minnesota, USA" & @CRLF & _
"2 SOUR @S0131@" & @CRLF & _
"3 PAGE Source Citation: Year: 1940; Census Place: Faribault, Rice, Minnesota; Roll: T627_1953; Page: 8B; Enumeration District: 66-9A" & @CRLF & _
"3 DATA" & @CRLF & _
"4 TEXT residence date: 1 Apr 1940 residence place: Faribault, Rice, Minnesot" & @CRLF & _
"5 CONC a, United States birth date: May 30, 1935 birth place: Minneapolis" & @CRLF & _
"5 CONC , Hennepin, Minnesota, USA Name: Joan Adrienne Hatch" & @CRLF & _
"3 NOTE @N0127@" & @CRLF & _
"1 RESI" & @CRLF & _
"2 DATE 1 APR 1940" & @CRLF & _
"2 PLAC Faribault, Rice, Minnesota, USA" & @CRLF & _
"2 SOUR @S0131@" & @CRLF & _
"3 PAGE Source Citation: Year: 1940; Census Place: Faribault, Rice, Minnesota; Roll: T627_1953; Page: 8B; Enumeration District: 66-9A" & @CRLF & _
"3 DATA" & @CRLF & _
"4 TEXT residence date: 1 Apr 1940 residence place: Faribault, Rice, Minnesot" & @CRLF & _
"5 CONC a, United States birth date: May 30, 1935 birth place: Minneapolis" & @CRLF & _
"5 CONC , Hennepin, Minnesota, USA Name: Joan Adrienne Hatch" & @CRLF & _
"3 NOTE @N0129@" & @CRLF & _
"1 FAMC @F1196@" & @CRLF & _
"1 FAMS @F0129@" & @CRLF & _
"1 FAMS @F0260@" & @CRLF & _
"1 CHAN" & @CRLF & _
"2 DATE 31 MAR 2017" & @CRLF & _
"3 TIME 22:03:40"
Local $sSubst = "\n $1 | $2 | $3 | $4 | $5 | $6 | $7 | $8 | $9 | $10 | $11 | $12 | $13 | $14 | |"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)