import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:https?://(?:[\\w-]+\\.)?(?:facebook\\.com|facebookwkhpilnemxj7asaniu7vnjjbiltxjqhye3mhbshg7kx5tfyd\\.onion)/(?:[^#]*?\\#!/)?(?:(?:video/video\\.php|photo\\.php|video\\.php|video/embed|story\\.php|watch(?:/live)?/?)\\?(?:.*?)(?:v|video_id|story_fbid)=|[^/]+/videos/(?:[^/]+/)?|[^/]+/posts/|groups/[^/]+/permalink/|watchparty/)|facebook:)(\\d+)";
final String string = "https://www.facebook.com/video.php?v=637842556329505&fref=nf\n"
+ "https://www.facebook.com/video.php?v=274175099429670\n"
+ "https://www.facebook.com/video.php?v=957955867617029\n"
+ "https://www.facebook.com/maxlayn/posts/10153807558977570\n"
+ "https://m.facebook.com/story.php?story_fbid=1035862816472149&id=116132035111903\n"
+ "https://www.facebook.com/barackobama/posts/10153664894881749\n"
+ "https://www.facebook.com/cnn/videos/10155529876156509/\n"
+ "https://www.facebook.com/yaroslav.korpan/videos/1417995061575415/\n"
+ "https://www.facebook.com/LaGuiaDelVaron/posts/1072691702860471\n"
+ "https://www.facebook.com/groups/1024490957622648/permalink/1396382447100162/\n"
+ "https://www.facebook.com/video.php?v=10204634152394104\n"
+ "https://www.facebook.com/amogood/videos/1618742068337349/?fref=nf\n"
+ "https://www.facebook.com/ChristyClarkForBC/videos/vb.22819070941/10153870694020942/?type=2&theater\n"
+ "facebook:544765982287235\n"
+ "https://www.facebook.com/groups/164828000315060/permalink/764967300301124/\n"
+ "https://zh-hk.facebook.com/peoplespower/videos/1135894589806027/\n"
+ "https://www.facebookwkhpilnemxj7asaniu7vnjjbiltxjqhye3mhbshg7kx5tfyd.onion/video.php?v=274175099429670\n"
+ "https://www.facebook.com/onlycleverentertainment/videos/1947995502095005/\n"
+ "https://www.facebook.com/WatchESLOne/videos/359649331226507/\n"
+ "https://www.facebook.com/100033620354545/videos/106560053808006/\n"
+ "https://www.facebook.com/watch/?v=647537299265662\n"
+ "https://www.facebook.com/PankajShahLondon/posts/10157667649866271\n"
+ "https://m.facebook.com/Alliance.Police.Department/posts/4048563708499330\n"
+ "https://www.facebook.com/groups/ateistiskselskab/permalink/10154930137678856/\n"
+ "https://www.facebook.com/watch/live/?v=1823658634322275\n"
+ "https://www.facebook.com/watchparty/211641140192478";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}