$re = '/^[a-z|A-Z|0-9]+[a-z|A-Z|0-9]/';
$str = '21wefffffff
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);