$re = '/^\(\d{3}\)\s?\d{3}\-\d{4}$/m';
$str = '(123)123-1234
(123) 123-1234
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);