re = /key: \'(.*?)\',\s*$/m
str = ' var newEncryptMode = \'\'
var Encrypt = {
key: \'a2ffa5c9be07488bbb04a3a47d3c5f6a\',
iv: \'64175472480004614961023454661220\',
nonce: null,
init: function () {
var nonce = this.nonceCreat();
this.nonce = nonce;
return this.nonce;
},
nonceCreat: function () {
var type = 0;
var deviceId = \'f8:b4:6a:aa:5d:96\';
var time = Math.floor(new Date().getTime() / 1000);
var random = Math.floor(Math.random() * 10000);
return [type, deviceId, time, random].join(\'_\');
},
oldPwd: function (pwd) {
if(newEncryptMode == 1){
return CryptoJS.SHA256(this.nonce + CryptoJS.SHA256(pwd + this.key).toString()).toString();
}else{
return CryptoJS.SHA1(this.nonce + CryptoJS.SHA1(pwd + this.key).toString()).toString();
}
},'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end