const regex = /{{\s*(.+?)\s*}}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{{\\s*(.+?)\\s*}}', 'g')
const str = `<!doctype html>
<html lang="en">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, user-scalable=no, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0">
<meta http-equiv="X-UA-Compatible" content="ie=edge">
<title>Temp demo</title>
</head>
<body>
<h1>Temp Demo</h1>
<p>Welcome to Temp Demo!</p>
<p>Today's date is {{ currentDate }}</p>
</body>
</html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}