using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^token=(.*)";
string input = @"token=123412acascasdaASDFADS
reset_token=SDFDFdsf12313ADADF";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}