re = /^([0-9]:)?([0-9]+[a-zA-Z0-9~.+]+)(-[0-9]+[a-zA-Z0-9~.+]+)?/
str = '1.0+32-s1beta1~svn1245'
# Print the match result
str.match(re) do |match|
puts match.to_s
end